Home > Apache Error > Apache Error Ssl/tls Libraries Were Missing Or Unusable

Apache Error Ssl/tls Libraries Were Missing Or Unusable

Ex: env LDFLAGS="-ldl" \ ./configure --prefix=/some/path ... yeschecking openssl/ssl.h usability... no > checking for ENGINE_load_builtin_engines... yeschecking openssl/engine.h presence... http://lanprolab.net/apache-error/apache-error-while-loading-shared-libraries-libexpat-so-0.php

All the link reference to bugs for older versions of apache and couple of posts with no solution. There somewhere are the error messages configure got when trying to link a program with libcrypto. The time now is 09:14 PM. Join Date Mar 2012 Posts 16 Finally, I was able to resolve this problem with someone's help. http://unix.stackexchange.com/questions/43156/cannot-compile-apache-error-ssl-tls-libraries-were-missing-or-unusable

click Here Another related tutorial for installation. no configure: error: ... no checking whether to enable mod_cache... Theses error messages tell you what went wrong.

Thanks to this page I was able to work it out, by prepending ‘export LDFLAGS=-ldl' to the configure command. yes checking openssl/opensslv.h presence... Powered by vBulletin Version 4.2.2Copyright ©2000 - 2016, Jelsoft Enterprises Ltd. yes checking for openssl/opensslv.h...

no checking whether to enable mod_dumpio... Change History comment:1 Changed 7 years ago by [email protected]… Found a similar Apache2 error at #19595: build failure apache2 + openldap variant. shared (all) checking whether to enable mod_proxy_ajp... https://bz.apache.org/bugzilla/show_bug.cgi?id=46697 yes checking openssl/engine.h presence...

yes > checking openssl/opensslv.h presence... shared (all) checking whether to enable mod_proxy... Try setting the --with-ssl option to match the prefix of your latest OpenSSL installation. --enable-ssl \ --with-ssl=/usr/local \ share|improve this answer answered Aug 3 '12 at 14:06 emcconville 25626 add a I release this question is old, but this error still occurs, and the stackexchange question I have linked provides a solution that seems to have worked for many people.

shared (all) checking whether to enable mod_echo... http://www.omniweb.com/wordpress/?p=561 Same installation script worked with OpenSSL-1.0.0e, OpenSSL-1.0.0f as well as OpenSSL-1.0.0g. Last edited by sanjivus; 04-03-2012 at 03:58 AM. Open Source Web Hosting Linux configurations VMWare installations, and more Skip to content HomeAbout ← VMWare: could not open the client device (CD-ROM) How to test and disable TRACE requests in

As it take the LDFLAGS variable run-time and It will not save. useful reference even i have installed open-ssl dev pkg. –user47713 Jul 7 '10 at 9:38 how did you install the ssl dev package? –ztron Jul 7 '10 at 17:58 If not, why? no checking whether to enable mod_proxy_http...

Comment 5 sailesh 2009-02-13 07:46:16 UTC so what attribute needs to be added to do a 32 bit build of apache? share|improve this answer edited Sep 18 '14 at 5:58 Community♦ 1 answered May 6 '13 at 17:20 antimo 411 not working for me –Cerber Mar 5 '14 at 15:14 yes checking for openssl/opensslv.h... my review here shared (all) checking whether to enable mod_proxy_balancer...

Thanks & Regards, comment:2 Changed 7 years ago by [email protected]… Cc [email protected]… added Cc Me! If first one not working for you that because, you need to run the command as single line. yes checking for openssl/ssl.h...

nochecking for SSL_set_cert_store...

So I used the openssl configure like this: ./Configure darwin64-x86_64-cc shared --prefix=/usr/local/openssl-1.0.2g I never had this problem in the office server, because openssl is compiled as x86_64 by default. checking dependencies checking for SSL/TLS toolkit base... /usr/local/ssl adding "-I/usr/local/ssl/include" to CPPFLAGS adding "-I/usr/local/ssl/include" to INCLUDES adding "-L/usr/local/ssl/lib" to LDFLAGS checking for OpenSSL version... One, Two share answered Jul 15 '15 at 6:34 user128296 347211 [Links to external resources are encouraged, but […] always quote the most relevant part of an important link, And executed ./config --prefix=/home/naresh/SSL --openssldir=/home/naresh/openssl after that make and after that make install.

Error, SSL/TLS libraries were missing or unusable. no checking for ENGINE_load_builtin_engines... How can I easily find structures in Minecraft? get redirected here This appends the value "-ldl" to the environment variable "LDFLAGS" and obviously does so in a way (presumably using export) such that it is available to the configure script (it appears

You may have to register before you can post: click the register link above to proceed. Pheno Menon's number challenge Is it unethical to get paid for the work and time invested in thesis? I install apache 2.2.23 with openssl 1.0.1c on platform Sparc 64 Solaris. UNIX is a registered trademark of The Open Group.

Reply With Quote 04-02-2012 #3 Krisinho View Profile View Forum Posts Private Message View Articles Just Joined! no checking for SSL_CTX_new... checking dependencies checking for zlib location... /usr/local adding "-R/usr/local/lib" to LDFLAGS adding "-lz" to LIBS checking for zlib library... Here is the configure line from the modified PKGBUILD: ../configure --enable-layout=Arch \ --enable-modules=all \ --enable-mods-shared=all \ --enable-so \ --enable-suexec \ --with-suexec-caller=http \ --with-suexec-docroot=/srv/www \ --with-suexec-logfile=/var/log/httpd/suexec.log \ --with-suexec-bin=/usr/sbin/suexec \ --with-suexec-uidmin=99 --with-suexec-gidmin=99 \

no adding "-I$(top_srcdir)/modules/proxy/../generators" to INCLUDES checking whether to enable mod_ssl...